Opened 8 years ago

Closed 8 years ago

#1517 closed bug (fixed (in master))

Crash if too many items displayed

Reported by: magnate Owned by:
Milestone: 3.3.1 Keywords: items
Cc:

Description

Change History (3)

comment:1 Changed 8 years ago by takkaria

I think this is a limit of the Term package, and if so this bug should also be present in 3.2.0.

comment:2 Changed 8 years ago by magnate

  • Status changed from new to confirmed

I can confirm that this bug happens with the savefile attached to the Oook thread. I can also confirm that the bug is related to the "item list" subwindow: if you go into window settings and turn that off, you can toggle K with impunity.

comment:3 Changed 8 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed

The problem was MAX_ITEMLIST being set to 256 in defines.h. There were no comments to explain why it was set at that level, or why it exists at all, so I just added a 0 on the end. Fixed in master as [rd6fb08b] and in 3.3-release as [r5a36070].

Note: See TracTickets for help on using tickets.