Opened 6 years ago

Closed 5 years ago

#1531 closed bug (fixed (in master))

Protect against phantom pvals

Reported by: magnate Owned by: magnate
Milestone: 3.4.0 Keywords: items
Cc:

Description

http://angband.oook.cz/forum/showthread.php?t=4867

If a base item has a negative pval, and then has an ego template applied which boosts that flag to a net value of zero, we end up with num_pvals as 1 and the pval_flag erroneously in place. PowerWyrm helpfully provides the solution as well as the problem.

Change History (8)

comment:1 Changed 6 years ago by PowerWyrm

See the thread for another related problem.

comment:2 Changed 6 years ago by magnate

  • Milestone changed from 3.3.1 to 3.4.0
  • Status changed from new to confirmed

This isn't actually an issue in 3.3, because there are no items which can end up with a pval of 0.

comment:3 Changed 5 years ago by magnate

  • Status changed from confirmed to pending

These are all done (or at least underway) in http://github.com/magnate/angband/tree/affixes.

comment:4 Changed 5 years ago by magnate

  • Keywords items,affixes added; items removed

This ticket is addressed in (or enabled by) https://github.com/angband/angband/pull/94

comment:5 Changed 5 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:6 Changed 5 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from pending to closed

Fixed in the affixes merge [r48ccc16f]

comment:7 Changed 5 years ago by magnate

  • Keywords items added; items,affixes removed
  • Milestone changed from 4.0 to 3.4.0
  • Resolution fixed (in v4) deleted
  • Status changed from closed to reopened

This needs cherry-picking for 3.4.0

comment:8 Changed 5 years ago by magnate

  • Resolution set to fixed (in master)
  • Status changed from reopened to closed

[r7a72a2c]

Note: See TracTickets for help on using tickets.