Opened 7 years ago

Closed 7 years ago

#1541 closed bug (worksforme)

Crash on dying, 3.3.1

Reported by: vext01 Owned by:
Milestone: Triage Keywords:
Cc:

Description

This GDB was configured as "amd64-unknown-openbsd5.0"...
(gdb) run -msdl
Starting program: /usr/local/bin/angband -msdl
[New process 10744]
[New process 10744, thread 0x20c01a000]

Program received signal SIGSEGV, Segmentation fault.
[Switching to process 10744, thread 0x202338000]
0x000000000048b7f6 in file_lock (f=0x0) at z-file.c:433
433 lock.l_type = (f->mode == MODE_READ ? F_RDLCK : F_WRLCK);
(gdb) bt
#0 0x000000000048b7f6 in file_lock (f=0x0) at z-file.c:433
#1 0x00000000004633e6 in enter_score (death_time=Variable "death_time" is not available.
) at score.c:188
#2 0x000000000041386f in death_screen () at death.c:426
#3 0x000000000041ab8c in close_game () at files.c:1795
#4 0x0000000000416043 in play_game () at dungeon.c:1840
#5 0x000000000049147a in main (argc=1, argv=0x7f7fffff0df0) at main.c:445

Cheers

Attachments (1)

angband.tgz (4.9 KB) - added by vext01 7 years ago.
save file (as requested)

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by vext01

Sorry:

This GDB was configured as "amd64-unknown-openbsd5.0"...
(gdb) run -msdl
Starting program: /usr/local/bin/angband -msdl
[New process 10744]
[New process 10744, thread 0x20c01a000]

Program received signal SIGSEGV, Segmentation fault.
[Switching to process 10744, thread 0x202338000]
0x000000000048b7f6 in file_lock (f=0x0) at z-file.c:433
433             lock.l_type = (f->mode == MODE_READ ? F_RDLCK : F_WRLCK);
(gdb) bt
#0  0x000000000048b7f6 in file_lock (f=0x0) at z-file.c:433
#1  0x00000000004633e6 in enter_score (death_time=Variable "death_time" is not available.
) at score.c:188
#2  0x000000000041386f in death_screen () at death.c:426
#3  0x000000000041ab8c in close_game () at files.c:1795
#4  0x0000000000416043 in play_game () at dungeon.c:1840
#5  0x000000000049147a in main (argc=1, argv=0x7f7fffff0df0) at main.c:445

Changed 7 years ago by vext01

save file (as requested)

comment:2 Changed 7 years ago by magnate

Cannot reproduce with this savefile on Linux. Please provide instructions on how to reproduce the crash, i.e. keypress by keypress.

comment:3 Changed 7 years ago by magnate

  • Resolution set to worksforme
  • Status changed from new to closed

Closed by agreement with submitter on IRC 26/09/11 - unreproducible.

Note: See TracTickets for help on using tickets.