Opened 8 years ago

Closed 7 years ago

#1544 closed bug (fixed (in master))

Proof in-game help for typos and obsolete refs

Reported by: AapoRantalainen Owned by: fizzix
Milestone: 3.4.0 Keywords: help patch
Cc:

Attachments (8)

attack.txt (34.9 KB) - added by PowerWyrm 8 years ago.
Reviewed version of attack.txt. Mainly fixes outdated ego items.
birth.txt (30.0 KB) - added by PowerWyrm 8 years ago.
Reviewed version of birth.txt. Fixes outdated values for race/class bonus tables.
command.txt (35.3 KB) - added by PowerWyrm 8 years ago.
Reviewed version of command.txt. Added missing commands and updated some.
customize.txt (15.0 KB) - added by PowerWyrm 8 years ago.
Reviewed version of customize.txt. Fixed one typo.
dungeon.txt (25.0 KB) - added by PowerWyrm 8 years ago.
Reviewed version. Fixes a couple of typos.
general.txt (17.8 KB) - added by PowerWyrm 8 years ago.
Fixed one typo.
option.txt (14.9 KB) - added by PowerWyrm 8 years ago.
Fixed some typos. Added reference to "lazymove_delay" and "Display status".
playing.txt (16.8 KB) - added by PowerWyrm 8 years ago.
Updated command list for both keysets.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 8 years ago by PowerWyrm

When reviewing help files for my variant (by doing a WinDiff? with the Angband files), I found a bunch of typos and obsolete references in the current help files (race/class stat boni for example). Instead of creating specific issues, there should probably be a "review help files" general issue.

I will do another review of those files when I release the next version for my variant. If nobody has opened an issue since then, I'll do it and post all my updates.

comment:2 Changed 8 years ago by magnate

  • Keywords help added
  • Milestone changed from Triage to 3.4.0
  • Status changed from new to confirmed
  • Summary changed from dungeon.txt missing end of sentence to Proof in-game help for typos and obsolete refs

The bug is filed against 3.3.0, but fph has done a lot of work since then in converting the help to RST, so may have picked up a number of the typos etc. But yes, they can always do with another pass - tagging for 3.4

Changed 8 years ago by PowerWyrm

Reviewed version of attack.txt. Mainly fixes outdated ego items.

Changed 8 years ago by PowerWyrm

Reviewed version of birth.txt. Fixes outdated values for race/class bonus tables.

Changed 8 years ago by PowerWyrm

Reviewed version of command.txt. Added missing commands and updated some.

Changed 8 years ago by PowerWyrm

Reviewed version of customize.txt. Fixed one typo.

Changed 8 years ago by PowerWyrm

Reviewed version. Fixes a couple of typos.

Changed 8 years ago by PowerWyrm

Fixed one typo.

Changed 8 years ago by PowerWyrm

Fixed some typos. Added reference to "lazymove_delay" and "Display status".

Changed 8 years ago by PowerWyrm

Updated command list for both keysets.

comment:3 Changed 8 years ago by PowerWyrm

All affected files have been attached. I hope I didn't break the whole formatting of these files...

comment:4 Changed 8 years ago by magnate

Many thanks for your work. I *think* we're moving towards RST being the authoritative helpfile format, but hopefully fph (who did the initial conversion) will be able to do these updates by diffing against the versions in master.

comment:5 Changed 8 years ago by magnate

  • Keywords patch added
  • Status changed from confirmed to pending

comment:6 Changed 7 years ago by PowerWyrm

In the current help files, there are some words starting with "s" that have the "s" missing: (s)quare, (s)et, (s)taff, (s)imply, (s)afe...

fph fixed a lot of these errors, but some remain.

comment:7 Changed 7 years ago by fizzix

  • Description modified (diff)
  • Status changed from pending to confirmed

comment:8 Changed 7 years ago by fizzix

  • Owner set to fizzix
  • Status changed from confirmed to assigned

comment:9 Changed 7 years ago by myshkin

The in-game help browser does not fully understand RST. In particular, the double-backquote syntax for inline literals gets displayed as-is, and so we get lots of extraneous backquotes. Press ? e (Playing the game) for lots of examples. files.c:show_file() needs to account for this behavior.

comment:10 Changed 7 years ago by fizzix

Proofing the in-game help is something that needs to be done prior to every release. Therefore, it has been added to the release checklist, as a recurring task rather than a bug. The documents are up to date for 3.4.

http://trac.rephial.org/wiki/ReleaseChecklist

Last edited 7 years ago by fizzix (previous) (diff)

comment:11 Changed 7 years ago by fizzix

  • Description modified (diff)
  • Resolution set to fixed (in master)
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.