Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1621 closed bug (worksforme)

Crash associated with Nar the Dwarf

Reported by: Motyob Owned by: myshkin
Milestone: Triage Keywords: mac
Cc:

Description

Running Angband 3.3.0-546-ga 48326c-dirty
System: Mac OS X 10.6.8

Everything seems to work fine up to the first time I encounter Nar the dwarf. As soon as I try to attack him the program crashes. After that I can no longer look at the monster screen or I get the same crash. So far as long as I avoid him, and do not go to the monster screen (~ then d) it works fine.

I am attaching the save file hoping it will help.

Attachments (1)

Imagon (100.4 KB) - added by Motyob 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Motyob

comment:1 Changed 7 years ago by magnate

Ok, I can't reproduce this, either with your savefile or a fresh one. I can summon Nar, hit him, and look at his recall entry. This is with -mgcu, so needs someone else to test on a Mac.

comment:2 Changed 7 years ago by myshkin

  • Owner set to myshkin
  • Status changed from new to assigned

I tried reproducing this on an Intel Mac running 10.6.8. I used the Carbon build of ga48326c (slightly different tag, as the 3.4-dev label is now the most recent parent), and successfully attacked Nar from wizard mode without a crash. I do get the square boxes that indicate UTF-8 issues (to be fixed in 3.4).
Motyob, do you get a crash report? If so, can you paste it? You don't need to send it to Apple; just show the details and cut and paste from the crash window.

comment:3 Changed 7 years ago by fizzix

Also attempted to reproduce on 3.4 in windows, and failed. I'm guessing we can close this?

comment:4 Changed 7 years ago by fizzix

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:5 Changed 7 years ago by myshkin

  • Keywords mac added

Motyob, we're closing this as not reproducible. If you are still encountering this problem, please reopen the ticket and supply the crash report. Thanks!

Note: See TracTickets for help on using tickets.