Opened 7 years ago

Closed 6 years ago

#1625 closed bug (fixed (in master))

Autotools/buildsys build fails by default

Reported by: myshkin Owned by: noz
Milestone: 3.4.0 Keywords: unix,compat,build
Cc:

Description

The default settings to configure (i.e. sdl-mixer enabled and sdl disabled) fail to add -lSDL to the LIBS, but snd-sdl.c relies on functions in that library (specifically, SDL_RWFromFile(), via the Mix_LoadWAV macro), at least in the version of SDL I have. Reported by bacchist in #angband-dev.

Attachments (2)

typescript (25.9 KB) - added by myshkin 6 years ago.
Transcript of build session
config.log (23.0 KB) - added by myshkin 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by myshkin

Possibly related to #1153.

comment:2 Changed 7 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0
  • Status changed from new to confirmed

Surely the solution here is to change the default sdl-mixer config to disabled?

(Changing milestone to 3.4 as per other buildsys tickets - not specific to v4.)

comment:3 Changed 7 years ago by myshkin

It is possible that we should do so, but that won't fix the problem, unless we also add a dependency such that --enable-sdl-mixer requires --enable-sdl.

comment:4 Changed 7 years ago by magnate

  • Keywords unix,compat,build added; unix compat removed
  • Owner set to noz
  • Status changed from confirmed to assigned

comment:5 Changed 6 years ago by noz

Hmmm. Works for me on debian (wheezy). I did:

$ ./autogen.sh
$ ./configure --with-no-install
$ make clean; make

and it built fine.

myshkin - can you post a trace of what fails for you?

Changed 6 years ago by myshkin

Transcript of build session

comment:6 Changed 6 years ago by myshkin

noz, see attached, from commit 173d165 of master.

Changed 6 years ago by myshkin

comment:7 Changed 6 years ago by myshkin

I should note that I'm running Ubuntu 11.10 (Oneiric Ocelot).

The link commands and output:

gcc -o angband angband.o main.o main-gcu.o main-x11.o snd-sdl.o   -L/usr/lib -lncursesw -ltinfo  -lSM -lICE  -lX11  -lSDL_mixer -lm
/usr/bin/ld: snd-sdl.o: undefined reference to symbol 'SDL_GetError'
/usr/bin/ld: note: 'SDL_GetError' is defined in DSO /usr/lib/libSDL-1.2.so.0 so try adding it to the linker command line
/usr/lib/libSDL-1.2.so.0: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

comment:8 Changed 6 years ago by myshkin

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed

Fixed in commit 955f77c in master.

Note: See TracTickets for help on using tickets.