Opened 8 years ago

Closed 6 years ago

#1626 closed bug (worksforme)

Crash with dubtrain's sound pack

Reported by: myshkin Owned by:
Milestone: 3.5.0 Keywords: sdl sound
Cc:

Description

Reported by bacchist on #angband-dev:

bacchist: *** glibc detected *** src/angband: double free or corruption (!prev): 0x00000000012643f0 ***
bacchist: when trying to use dubtrain's sound pack with v4

I have not personally reproduced the problem, nor do I know whether it's limited to v4 or also present in V.

Change History (4)

comment:1 Changed 8 years ago by magnate

I can confirm that it isn't present in 3.3.2; haven't tried 3.4-dev

Is this specific to the SDL port? It doesn't happen in x11 or gtk or gcu? (Or don't they support sound?)

comment:2 Changed 8 years ago by magnate

Oooh, wait a minute. I remember that I had to convert dubtrain's WAVs to ogg files for the angband-audio package. ISTR some weird error that SDL can't handle "high density" WAVs, or something. They worked ok in -mgcu though, I think, so that explains the SDL keyword.

If I've remembered correctly, this is a problem with SDL's lack of support for the particular WAV format Dubtrain used. AFAICT it isn't something we can fix in angband. *nix users should be encouraged to use the deb/rpm packages (which have the sounds converted to oggs); people building from source and using Dubtrain's sounds should just use a different display module.

(FWIW I have a new mentor, so angband-audio might get uploaded to Debian and Ubuntu soon.)

comment:3 Changed 7 years ago by takkaria

  • Milestone changed from Triage to 3.5.0

Assigning open bugs to 3.5 for fixing.

comment:4 Changed 6 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

The Dubtrain sound pack is now included as MP3, so we don't have this problem with WAVs.

Note: See TracTickets for help on using tickets.