Opened 8 years ago

Closed 7 years ago

#1654 closed bug (fixed (in master))

Game crashes when "reset layout" is selected on XP and Vista

Reported by: fizzix Owned by:
Milestone: 3.5.0 Keywords: windows, graphics, blocker
Cc:

Description

Simple solution is to remove the "reset layout" option. Which is the path I'll take if no one can fix it for 3.4.0

Change History (6)

comment:1 Changed 8 years ago by PowerWyrm

Also reproduced on Win7 when selecting the option at splash screen.

comment:2 Changed 8 years ago by PowerWyrm

Note that the game simply crashes on Win7 64, not only when selecting "reset layout", but also when the game launches itself after character creation/selection. This happens in ReadDIB2_PNG() when loading the tiles from the png file. I suspect an incompatibility with the version of libpng/zlib used to compile Angband (the version used is 1.2.37, which is really outdated). For my variant, I use libpng 1.5.4 and I don't have this problem...

Concerning the crash when selecting "reset layout" at splash screen, the feature calls reset_visuals() which loads graf.prf. This cannot work because p_ptr is accessed during the call, and it's not properly initialized at that time. The solution is to disable "reset layout" until a character is selected.

Version 1, edited 8 years ago by PowerWyrm (previous) (next) (diff)

comment:3 Changed 8 years ago by magnate

  • Keywords windows added; Windows, removed
  • Status changed from new to confirmed

This feature has been temporarily disabled in [a945067], so this could be punted if the bug is not fixed for release.

comment:4 Changed 8 years ago by fizzix

  • Milestone changed from 3.4.0 to 3.5.0

comment:5 Changed 7 years ago by takkaria

  • Keywords windows, graphics, blocker added; windows graphics removed

comment:6 Changed 7 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

This was actually fixed in 102b3b13

Note: See TracTickets for help on using tickets.