Opened 7 years ago

Closed 6 years ago

#1672 closed bug (worksforme)

Pickup prompts for "which item" unnecessarily

Reported by: fizzix Owned by:
Milestone: 3.5.0 Keywords:
Cc:

Description

When picking up an item on the floor which is stacked with a squelched item there is a prompt for "which item" with only the unsquelched item shown. If an item is alone on the floor, there is no "which item" prompt.

Change History (3)

comment:1 Changed 7 years ago by noz

At first sight, this looks easy - just call scan_floor() with mode == 0x03 instead of 0x01 in py_pickup() at cmd1.c:476. This returns the correct number of visible items, and will avoid the prompt for a single item.

However, further down in py_pickup(), if only a single item is there, the index is taken with floor_list[0], which is not necessarily valid, if the single item was in a stack of other squelched items.

comment:2 Changed 7 years ago by takkaria

  • Milestone changed from Triage to 3.5.0

Assigning open bugs to 3.5 for fixing.

comment:3 Changed 6 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

This has been fixed in the meantime since I can't reproduce it now (and the 0x03 mentioned in the above comment is now 0x08).

Note: See TracTickets for help on using tickets.