Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#1694 closed bug (worksforme)

Veins don't light up properly under some circumstances in text mode.

Reported by: Red Owned by: molybdenum
Milestone: 3.5.0 Keywords:
Cc:

Description

When in text mode, the veins (magma/quartz) usually don't light up properly, though sometimes they do.

Note that they light up properly in graphics mode!

From the looks of it, the squares only light up if the vein is on the screen when you load a new level, though I can't verify this.

Reproduce: Create a new game, go into the dungeon a and find quartz/magma veins. (%) Ideally not on the original screen you appeared on.

Confirmed on:
Windows 3.4
Android 3.3.2, 3.4
Ubuntu 3.3.2
OSX 3.4dev (2012/10/14, by myshkin, thanks for your time)

Attachments (1)

ubuntu.png (9.6 KB) - added by Red 7 years ago.
Showing both lit and unlit veins on Ubuntu, 3.3.2 (unlit upper left, lit bottom right)

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Red

Showing both lit and unlit veins on Ubuntu, 3.3.2 (unlit upper left, lit bottom right)

comment:1 Changed 7 years ago by Red

Upon further investigation, I was certain I checked that, but apparently, I was too tired.

In terrain.txt:

  • Magma veins are color "s"
  • Quartz veins are color "w"

"w" light up properly but "s" acts weird on all platforms, or at least not as one would expect for a wall.

Chaging magma veins to "w" fixes the undesired effect, however I would beleive we'd rather keep magma veins a different color...

comment:2 Changed 7 years ago by Red

Even more notes... And why one should not log bugs at 2am.

I just remembered, back in the 16color days, that the "dark grey" was actually "light black", so to speak, this means that the "s" color is already "illuminated" per say, since the "light" flag in the byte is already set...

I didn't notice the color difference since nowadays term windows are so small, the contrast wasn't noticeable on that tiny character...

comment:3 Changed 7 years ago by Red

Still in 3.4.1 obviously... Is there anyone objecting the validity of putting the color to "w"?

comment:4 Changed 6 years ago by takkaria

  • Milestone changed from Triage to 3.5.0

Assigning open bugs to 3.5 for fixing.

comment:5 Changed 6 years ago by molybdenum

  • Owner set to molybdenum
  • Status changed from new to assigned

comment:6 Changed 6 years ago by myshkin

Is this still occurring? I'm now having trouble reproducing it. Red, could you confirm?

comment:7 Changed 6 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from assigned to closed

Can't be reproduced. Please reopen if you still get this.

comment:8 Changed 6 years ago by Red

I'll try and check it out next week, I don't have... *any* development environment setup on any of my computers right now :p

Note: See TracTickets for help on using tickets.