Opened 7 years ago

Closed 6 years ago

#1724 closed bug (duplicate)

SDL port crash on exit with stack trashing

Reported by: hboetes Owned by:
Milestone: 3.5.0 Keywords: sdl
Cc:

Description

This crash happened with the git code from yesterday after exiting.

Core was generated by `/mega/home/han/src/Angband/angband.main/src/angband -msdl'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000000054080c in Term_resize (w=0, h=0) at z-term.c:2348
2348		term_win_copy(Term->old, hold_old, wid, hgt);
(gdb) bt
#0  0x000000000054080c in Term_resize (w=0, h=0) at z-term.c:2348
#1  0x0000000000540dc1 in term_nuke (t=0xbffffffff) at z-term.c:2560
#2  0x0000000000487f8b in wr_player () at save.c:409
#3  0x00007f4311d244f0 in ?? ()
#4  0x0000000000000000 in ?? ()

Change History (3)

comment:1 Changed 7 years ago by takkaria

  • Keywords sdl added
  • Milestone changed from Triage to 3.5.0

Wow, I have no idea what caused that - the stack is totally trashed! wr_player() doesn't call term_nuke and term_nuke() doesn't call Term_resize()... If you get anything like this again could you please post it to this bug?

comment:2 Changed 7 years ago by takkaria

  • Summary changed from crash upon exit to SDL port crash on exit with stack trashing

comment:3 Changed 6 years ago by takkaria

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1726

Note: See TracTickets for help on using tickets.