Opened 5 years ago

Closed 5 years ago

#1727 closed bug (fixed (in master))

drop all doesn't work like expected

Reported by: hboetes Owned by:
Milestone: 3.5.0 Keywords:
Cc:

Description (last modified by takkaria)

how to repeat:

  1. walk into your home
  2. hit 'i'
  3. click on a stack (e.g. arrows)

At the right you get a menu with two items: drop and drop all.

'Drop all' asks for confirmation and then drops stuff outside of your house. It has the same letter as 'd'rop.

What I would expect is that drop all can be selected with D and that it drops all items in the stack _in_ your house, without a confirmation.
I don't like to see confirmation requests on stuff that's easily mended.

Change History (4)

comment:1 Changed 5 years ago by takkaria

  • Description modified (diff)

comment:2 Changed 5 years ago by takkaria

  • Milestone changed from Triage to 3.5.0

Potentially one for 3.5, but I suggest that right now this is actually working as intended - that menu drops on the floor wherever it's used.

comment:3 Changed 5 years ago by takkaria

  • Type changed from change to bug

comment:4 Changed 5 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from new to closed

Fixed in bf5b150

Note: See TracTickets for help on using tickets.