Opened 7 years ago

Closed 6 years ago

#1729 closed bug (wontfix)

save-file compatibility is broken.

Reported by: pete mack Owned by:
Milestone: 3.5.0 Keywords:
Cc:

Description (last modified by takkaria)

Created a 3.3.0 file (from latest download shown at oook). Then upgraded to 3.4.1 from rephial.

Can't examine torch (crash):

Bad call to which_pval: flag is 67, kidx is 2

I tried examining the torch because light-radius was zero...

Suggested fix: update version compat # (or fix 0 pval during load)

Also: update OOOK version!

Change History (3)

comment:1 Changed 7 years ago by takkaria

  • Description modified (diff)

We can't update the version on oook, that's Pav's thing :/

I think we should change our savefile compat policy to 'dead characters only between versions'.

comment:2 Changed 7 years ago by takkaria

  • Milestone changed from Triage to 3.5.0

Assigning open bugs to 3.5 for fixing.

comment:3 Changed 6 years ago by takkaria

  • Resolution set to wontfix
  • Status changed from new to closed

Added note to 3.5 changes.txt about savefile compat in [18d4b2a]. Basically, don't expect compatibility for alive characters.

Note: See TracTickets for help on using tickets.