Opened 6 years ago

Closed 5 years ago

#1744 closed bug (fixed (in master))

Monster pathfinding is weird and wrong

Reported by: takkaria Owned by: fizzix
Milestone: 3.5.0 Keywords: monster ai
Cc:

Description

  • Monsters don't run away properly when afraid
  • Monsters fail to get around simple obstacles

Change History (3)

comment:1 Changed 5 years ago by fizzix

  • Owner set to fizzix
  • Status changed from new to assigned

comment:2 Changed 5 years ago by fizzix

Monsters behave appropriately when afraid.

I could not reproduce the bugs about monster pathing. Unless we can get a specific example of what is wrong, I'm not sure how to fix it. I did extensively check to ensure that the flow values for monster pathing were correct. I also attempted to recreate the previous results which showed problems and was unsuccessful. I'm going to close this ticket for now until there's more information about what is wrong.

comment:3 Changed 5 years ago by fizzix

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.