Opened 7 years ago

Closed 5 years ago

#1753 closed bug (worksforme)

Inscribing items in the quiver causes a crash

Reported by: myshkin Owned by:
Milestone: 3.5.1 Keywords: inscriptions, windows, blocker
Cc:

Description (last modified by takkaria)

In #angband-dev, Amnekian reported that starting a new character, buying arrows, wielding them, and inscribing them with @fN where N is not 0 causes a crash on Windows 7 with both 3.4.1 and f46e00f of master. I cannot reproduce this problem on OS X.

Another report here: http://angband.oook.cz/forum/showthread.php?p=95556 with request for clarification

Change History (8)

comment:1 Changed 6 years ago by takkaria

  • Milestone changed from Triage to 3.5.0

comment:2 Changed 6 years ago by takkaria

  • Keywords windows added

Can't reproduce under Valgrind either.

comment:3 Changed 6 years ago by takkaria

  • Keywords inscriptions, windows, blocker added; inscriptions windows removed

comment:4 Changed 6 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

Closing, since I can't reproduce on OS X or on Windows

comment:5 Changed 5 years ago by takkaria

  • Description modified (diff)
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reopening as it's been reported again in 3.5 and it's a crash bug.

comment:6 Changed 5 years ago by takkaria

  • Milestone changed from 3.5.0 to 3.5.newt-knows

comment:7 Changed 5 years ago by noz

Cannot reproduce this under 3.5.0 (actually 3.5-release c1c8258) on Windows XP. Now need to find some way of testing on Windows 7, ho hum.

comment:8 Changed 5 years ago by magnate

  • Resolution set to worksforme
  • Status changed from reopened to closed

Not reproducible under win7 or linux from the latest 3.5-release: closing.

Note: See TracTickets for help on using tickets.