Opened 5 years ago

Closed 5 years ago

#1790 closed bug (fixed (in master))

Monsters 'cackling evilly about traps' can delete runes of protection

Reported by: takkaria Owned by: molybdenum
Milestone: 3.5.0 Keywords:
Cc:

Change History (5)

comment:1 Changed 5 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from new to closed

Fixed in b020e2c, pull request https://github.com/angband/angband/pull/276

comment:2 Changed 5 years ago by PowerWyrm

  • Resolution fixed (in master) deleted
  • Status changed from closed to reopened

The fix is useless: the code already checks for cave_isempty() which ensures that the current square is a floor square. The bug in 3.4.1 is obsolete in 3.5. You can revert this change.

comment:3 Changed 5 years ago by molybdenum

Hm, yes. I'm almost positive I was able to reproduce the bug; hence why I made the fix. But everything seems to be working without the warding check.

comment:4 Changed 5 years ago by molybdenum

  • Owner set to molybdenum
  • Status changed from reopened to assigned

comment:5 Changed 5 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.