Opened 4 years ago

Last modified 3 years ago

#1793 new bug

Inven/equip context menus fail to allow dropping

Reported by: takkaria Owned by:
Milestone: Future Keywords:
Cc:

Description

"Finally, dropping items from inventory/equipment menus still has persistent, albeit intermittent, bugs. For example, you id an item and go to drop it, but the option isn't available. You have to leave the menus, select "d"rop and then drop the item. Still haven't figured out why this is intermittent. Possibly in connection with having inscriptions on the items, and/or items being ego or artifact items, and/or items in the quiver?"

from http://angband.oook.cz/forum/showthread.php?t=6357

Change History (2)

comment:1 follow-up: Changed 3 years ago by molybdenum

I can't reproduce this as of dd17148e2860. I have tried dropping the following by context menu, both from the inventory list and the equipment list, and all drop correctly:

  • artifacts
  • ego armor and weapons
  • ego arrows and regular arrows (dropping one and dropping all)
  • inscribed weapons and arrows
  • unidentified weapons and freshly identified weapons

comment:2 in reply to: ↑ 1 Changed 3 years ago by molybdenum

Replying to molybdenum:

I can't reproduce this as of dd17148e2860. I have tried dropping the following by context menu, both from the inventory list and the equipment list, and all drop correctly:

  • artifacts
  • ego armor and weapons
  • ego arrows and regular arrows (dropping one and dropping all)
  • inscribed weapons and arrows
  • unidentified weapons and freshly identified weapons

Somehow, I did manage to get this to happen, but it fixed itself on relaunch so I couldn't trace it. I had generated a bunch of items, picked them up, dropped/thrown a bunch and then some arrows and a few mushrooms weren't droppable at all.

Note: See TracTickets for help on using tickets.