Opened 6 years ago

Closed 5 years ago

#1818 closed bug (fixed (in master))

Examining fails after a lack of item to identify

Reported by: nckmccnnll Owned by:
Milestone: 3.5.1 Keywords: UI, ID
Cc:

Description

If you try to use identify and get the "You have nothing to identify" message, immediate use of the inspect command gives the "You have nothing to examine" message.

Change History (4)

comment:1 Changed 5 years ago by magnate

Very arcane indeed. This does NOT happen if you get any subsequent message after "You have nothing to identify" - such as "You re-order some items in your pack." or even "Welcome to level 2."

comment:2 Changed 5 years ago by magnate

  • Status changed from new to confirmed

comment:3 Changed 5 years ago by noz

It happens because the item_tester_hook remains set to item_tester_unknown. Obviously there are several things that clear that hook, but doing an examine straight after an unsuccessful identify doesn't. Can't see yet where to fix it, but will keep looking.

comment:4 Changed 5 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.