Opened 2 years ago

Last modified 22 months ago

#1840 assigned bug

Ensure Visual Studio compatibility

Reported by: nckmccnnll Owned by: nckmccnnll
Milestone: Future Keywords:
Cc:

Description

Things like

static struct init_module arrays_module = {
.name = "arrays",
.init = init_arrays,
.cleanup = cleanup_arrays
};

are too confusing for it.

Change History (3)

comment:1 Changed 2 years ago by nckmccnnll

  • Milestone changed from Triage to 4.0
  • Owner set to nckmccnnll
  • Status changed from new to assigned

comment:2 Changed 2 years ago by myshkin

As I suggested in IRC, a move to style like

static struct init_module arrays_module = {
    /* .name = */    "arrays",
    /* .init = */    init_arrays,
    /* .cleanup = */ cleanup_arrays
};

might be a good compromise between compatibility and readability. It does make for more work and possible confusion if struct members change, though.

comment:3 Changed 22 months ago by nckmccnnll

  • Milestone changed from 4.0 to Future

Kicking this one to future

Note: See TracTickets for help on using tickets.