Opened 4 years ago

Closed 3 years ago

#1910 closed bug (fixed (in master))

Resting issues

Reported by: nckmccnnll Owned by:
Milestone: 4.0 Keywords:
Cc:

Description

"I feel like there's something up with the resting mechanic, and possibly other repeat actions - in 3.5.1 you can rest hundreds of turns and the whole thing is over in a near instantaneous blip, but in 4.0 there are times when resting runs relatively quickly and other times when you can see the numbers visibly counting down and long rest periods take a perceptible amount of time to complete." - Nomad

I've seen this too

Change History (5)

comment:1 Changed 4 years ago by nckmccnnll

  • Summary changed from Resting slowdown to Resting issues

"Rest for set multiple turn counts, e.g., R10, is interrupted every turn by terror or hallucination. This is a change from previous versions. Interruption should only occur for monster or possibly poison." - Ingwe Ingweron

comment:2 Changed 3 years ago by nckmccnnll

The slowness is likely due to monster/item list updates, so these need to be optimised

comment:3 Changed 3 years ago by nckmccnnll

  • Status changed from new to confirmed

comment:4 Changed 3 years ago by nckmccnnll

It's just the slowdown that needs fixing now

comment:5 Changed 3 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Rest slowdown fixed in a05a05c (and related running slowdown fixed in c19952c)

Note: See TracTickets for help on using tickets.