Opened 4 years ago

Closed 3 years ago

#1945 closed bug (fixed (in master))

Game slowdown

Reported by: nckmccnnll Owned by:
Milestone: 4.0 Keywords:
Cc:

Description

Reported here: http://angband.oook.cz/forum/showpost.php?p=103385&postcount=14

Confirm that this is true, and that it appears to be due to monster processing

Change History (4)

comment:1 Changed 4 years ago by nckmccnnll

  • Status changed from new to confirmed

comment:2 Changed 4 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Fix by massively reducing visual updates in ecca701

comment:3 Changed 3 years ago by nckmccnnll

  • Resolution fixed (in master) deleted
  • Status changed from closed to reopened

Re-opening to try to do a better fix

comment:4 Changed 3 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from reopened to closed

Efficiency of object list improved in 2ec96cf on the 4.0-release branch - not in master, because changes to player knowledge code shortly to be pulled into master have the same effect.

Note: See TracTickets for help on using tickets.