Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1957 closed bug (fixed (in master))

Too many monsters in pain messages

Reported by: nckmccnnll Owned by:
Milestone: 4.0 Keywords:
Cc:

Description

"Sometimes the number of enemies in messages gets more than the actual number when you hit multiple targets. In my particular case, it shows "5 Dracoliches shrug off the attack" when there are only 2 of them." - yyt16384, http://angband.oook.cz/forum/showpost.php?p=105261&postcount=104

Change History (5)

comment:1 Changed 4 years ago by nckmccnnll

  • Status changed from new to confirmed

comment:2 Changed 4 years ago by nckmccnnll

The problem here is between add_monster_message() and redundant_monster_message(), and the way they identify a monster message as the same.

comment:3 Changed 4 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Fixed in a horribly hackish way in 464c24d

Last edited 4 years ago by nckmccnnll (previous) (diff)

comment:4 Changed 4 years ago by PowerWyrm

There was no need for a hack, because the bug is obvious: no entry is recorded in the (temporary) message history list when the message is already stored.

Also found a "Maxinum" typo while looking at that code ;)

comment:5 Changed 4 years ago by nckmccnnll

Duh

Note: See TracTickets for help on using tickets.