Opened 3 years ago

Closed 3 years ago

#1966 closed bug (fixed (in master))

Map window issues

Reported by: nckmccnnll Owned by: molybdenum
Milestone: 4.0 Keywords:
Cc:

Description

"I'm talking about the subwindow that appears when I go into Options->Subwindow Setup
and turn on "Display Map View" as it's own window.

There are two issues:

(1) It slows down re-drawing of the main window a lot. When I have it in the background, not shown as a full window, and am doing stuff in the main Angband (Cmd-0) window, re-draw on the main window slows down immensely. It takes nearly 5 seconds with redraw delay=0ms or 10ms to cross the screen. This slow down persists even if I minimize the subwindow or outright close(X) the subwindow.

(2) It gets buggy and fails to re-draw any part of the map that's off-limits. So, if I have the map large enough to show the whole dungeon, it exhibits the following behavior: if I'm centered in the middle of the dungeon, it looks good, and I can see the whole dungeon. Then, when I run to the right edge of the dungeon, it wants to re-center the drawing on my current @ position, forcing the left part of the dungeon off the map, and then on the right side of the subwindow, where there should be only blank space, the older full dungeon view is still visible, so you see a duplicate of the right side of the dungeon: One, part of the current re-draw with @ centered, and two, part of the previous re-draw showing the right edge of the dungeon. I can provide a screenshot if you can't reproduce this or don't understand.

[Update: (1) seems to happen even if I set it to overhead map instead of normal map]" - Nivra

Change History (3)

comment:1 Changed 3 years ago by PowerWyrm

IMO the two options are also reverted, since "Display map view" displays the normal (full) map and "Display overhead view" displays the minimap.

(2) happens for both minimap and full map: if you extend the size of the subwindow past a certain point (horizontally), its size seems to be reinitialized to 0 (sounds like a byte overflow to me)

comment:2 Changed 3 years ago by molybdenum

  • Owner set to molybdenum
  • Status changed from new to assigned

comment:3 Changed 3 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed

Fixed in 3739016 (for 4.0-release, 56b7366 in master)

Note: See TracTickets for help on using tickets.