Opened 2 years ago

Closed 2 years ago

#2022 closed bug (fixed (in master))

Torches fail to disappear

Reported by: nckmccnnll Owned by:
Milestone: 4.1 Keywords:
Cc:

Description

"Torches no longer disappear when they run out of fuel in the latest nightly; you're now just left with a Wooden Torch (0 turns). " - Nomad

Change History (4)

comment:1 Changed 2 years ago by nckmccnnll

  • Milestone changed from Triage to 4.1

Further: "Some related oddities - you no longer seem to get the warning messages to tell you when the light level is running low, and instead of the "your light has gone out" message when it completely runs out, you get "Your Wooden Torch has recharged."" - Nomad

But: "Update to this update: new game in the same nightly, just had the torch I started the game with behave perfectly correctly on running out; "Your light is growing faint" warnings, "Your light has gone out!" message, torch disappeared when out of fuel. Now I'm even more baffled..." - Nomad

comment:2 Changed 2 years ago by nckmccnnll

Can't reproduce, seeking clarification

comment:3 Changed 2 years ago by nckmccnnll

Wow. Problem was that artifact lights were all set to transfer their activation to the object kind, which meant that if a randart torch or lantern had an activation, it would transfer that activation and activation time to torch or lantern object kinds. This led to all torches/lanterns in such a game being treated like rods, where the timeout is used for recharge instead of light remaining, and all sorts of silliness ensued.

Fixed in 1b5084fc.

comment:4 Changed 2 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.