#2042 closed bug (fixed (in master))

Bad level generation, failure to phase

Reported by: nckmccnnll Owned by:
Milestone: Triage Keywords:
Cc:

Change History (2)

comment:1 Changed 18 months ago by nckmccnnll

Also http://angband.oook.cz/forum/showpost.php?p=122776&postcount=93

The problem is a level consisting of an isolated square (up stairs in the case of connected stairs) containing the player, and a vault. Phase fails because you can't teleport into a vault.

comment:2 Changed 18 months ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from new to closed

Phase made to fail gracefully in 36371b28, generation made to force at least two rooms in 474ea4d4.

Note: See TracTickets for help on using tickets.