Opened 10 years ago

Closed 10 years ago

#213 closed bug (fixed (in master))

.depend errors when using ./configure && make

Reported by: takkaria Owned by: takkaria
Milestone: 3.0.9 Keywords: autoconf
Cc:

Description

Not sure how to fix these.

Change History (6)

comment:1 follow-up: Changed 10 years ago by Elly

touch .depend before executing 'make depend'; that seems to get rid of this.

diff:

@@ -242,6 +242,10 @@

# default depend rule. if something else is needed -- override depend target
depend:

+ if [ ! -f .depend ]; then \
+ touch .depend; \
+ fi;
+

@if [ "x$(SUBDIRS)" != "x" ]; then \

for i in $(SUBDIRS); do \

if [ $(VERBOSITY) -gt 0 ]; then \

comment:2 in reply to: ↑ 1 Changed 10 years ago by Elly

Replying to Elly:
Oops, my diff didn't survive wiki formatting ;). It's a diff for 'mk/objective.mk', by the way.

touch .depend before executing 'make depend'; that seems to get rid of this.

diff:

@@ -242,6 +242,10 @@

# default depend rule. if something else is needed -- override depend target
depend:

+ if [ ! -f .depend ]; then \
+ touch .depend; \
+ fi;
+

@if [ "x$(SUBDIRS)" != "x" ]; then \

for i in $(SUBDIRS); do \

if [ $(VERBOSITY) -gt 0 ]; then \

comment:3 Changed 10 years ago by ajps

  • Keywords autoconf added

comment:4 Changed 10 years ago by takkaria

  • Owner set to takkaria
  • Status changed from new to assigned

comment:5 Changed 10 years ago by takkaria

[368] merged in [5dfe994] (SVN r399) contains something that works on Linux; need to check with BSD make also.

comment:6 Changed 10 years ago by takkaria

  • Resolution set to fixed
  • Status changed from assigned to closed

can't get BSD make to work properly with or without this fix, so just recommend gmake for now.

Note: See TracTickets for help on using tickets.