Opened 2 months ago

Closed 2 months ago

#2134 closed bug (fixed (in master))

Crash in block fall trap

Reported by: nckmccnnll Owned by:
Milestone: 4.2 Keywords:
Cc:

Description

Player steps on trap, game crashes, reloads to find a wall where trap was.

Change History (3)

comment:1 Changed 2 months ago by nckmccnnll

  • Milestone changed from Triage to 4.2

comment:2 Changed 2 months ago by nckmccnnll

  • Status changed from new to confirmed
  • Summary changed from Possible crash in block fall trap to Crash in block fall trap

See also http://angband.oook.cz/forum/showpost.php?p=140128&postcount=143, this is the same bug as #2136.

The problem is in hit_trap(), where the GRANITE effect removes the trap before trap->kind->effect_xtra can be checked.

Solution is to check square_trap() immediately after the effect (and the extra effect).

comment:3 Changed 2 months ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Fixed in f82d944aa

Note: See TracTickets for help on using tickets.