Opened 10 years ago

Closed 7 years ago

#232 closed bug (fixed (in master))

Solid block characters are invisible under Windows Vista

Reported by: ctate Owned by:
Milestone: 3.2.0 Keywords: windows
Cc:

Description

The solid block character generally referred to with character code 127 displays as a black space under Vista. This makes Angband unplayable as supplied in the standard .zip Windows distribution, since that invisible character is configured as the wall character.

Ideally the code should be fixed to use an appropriate display mechanism for graphics characters under Vista. A workaround might be to use the default '#' character for walls in the standard distribution.

Change History (13)

comment:1 Changed 10 years ago by takkaria

  • Resolution set to wontfix
  • Status changed from new to closed

See the FAQ. You just have to delete the block character lines.

We'll move to the SDL port eventually, I imagine, and this problem will go then.

comment:2 Changed 10 years ago by anonymous

Thanks for nothing.

comment:3 Changed 10 years ago by takkaria

I'm sorry, but either we remove all the pseudographics and get lots of complaints about needing them, and everyone who wants them has to fiddle with pref files to put them in, or Vista users, of whom there aren't currently that many, have to take out the lines. Given that the latter inconveniences fewer people than the former, that's the only reasonable decision to make.

comment:4 Changed 9 years ago by jasonite10@…

I'm a Vista user (as well as an XP user) and I finally installed a few Angband variants on my machine.... what a surprise this was.

I hope a solution can be found soon, it's too difficult to play without 'em! :)

comment:5 Changed 9 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.0
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Reopening this since it's something we want to fix. The very least we could do would be to detect whether Vista is being used or XP and switch to a different set of pref files if so.

(Though I'd still rather like to switch to SDL long-term.)

comment:6 Changed 9 years ago by takkaria

  • Keywords blocker added

comment:7 Changed 9 years ago by takkaria

  • Milestone changed from 3.1.0 to 3.1.1

[712d286] (SVN r1076) fixes this, but I'm reassinging to 3.1.1 because this needs a proper fix soon. The proper fix would involve going through all the font files that Nick hasn't and moving the wall character from its current position from 127 to something below character 16.

Nick's advice is as follows:

1. Sometimes (maybe always?) Windows doesn't like using characters
   16-31, or character 127 in the font. *Maintainers should avoid
   these in font-win.prf.*
2. Vista insists on using it's own 8x13 font, which has none of the
   useful things like wall blocks in it. *Players using Vista should
   not use 8x13 as a font size, and maintainers should use a
   different default size (say 18x12) in main-win.c.*

The other issue is that the default angband fonts were 75x75 dpi, and
Vista apparently requires 96x96.  I am pretty sure that all the fonts
on my page have been tested in Vista.  Also, the font-win.prf in FA0.3.5a
should be a good one to check against (except of course that some terrain
values may be different).

comment:8 Changed 9 years ago by takkaria

http://angband.oook.cz/faangband/Fonts.html is the page with the existing converted fonts on it.

comment:9 Changed 8 years ago by magnate

  • Keywords windows added

comment:10 Changed 8 years ago by takkaria

  • Status changed from reopened to confirmed

comment:11 Changed 8 years ago by takkaria

  • Keywords blocker removed
  • Milestone changed from 3.1.1 beta to 3.1.2 beta

bumping this fix to 3.1.2... again

comment:12 Changed 7 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:13 Changed 7 years ago by takkaria

  • Milestone changed from 3.3.0 to 3.2.0
  • Resolution set to fixed
  • Status changed from confirmed to closed

fixed in 3.2 already w Nick's xchars work

Note: See TracTickets for help on using tickets.