Opened 10 years ago

Closed 2 years ago

#234 closed task (fixed (in master))

Unify useable/eatable/spell code

Reported by: takkaria Owned by: takkaria
Milestone: Future Keywords: cleanup
Cc:

Description

Create effects.c, move everything into there. Eases maintenance.

Change History (17)

comment:1 Changed 10 years ago by takkaria

  • Status changed from new to assigned

comment:2 Changed 10 years ago by takkaria

first commit [df8323e] (SVN r317):

  • moves food over to effects.c
  • moves item nutrition info to lib/object.txt

issues:

  • doesn't print any use information on the "examine" screen

comment:3 Changed 10 years ago by takkaria

[bc0b314] (SVN r318) moves scrolls to effects.c

comment:4 Changed 10 years ago by takkaria

  • [c9c34d0] (SVN r319) moved rings across and added description code
  • [369d222] (SVN r320) moved artifacts across and further improved description code

current issues:

  • items are described to you regardless of ID status.
  • rods will not use charge

to bear in mind when moving rods across: make sure they don't give type away by not always prompting for a direction

comment:5 Changed 10 years ago by takkaria

[fe5e743] (SVN r321) fixes things that requiring aiming before use, moves the effect code from taking an object to taking an effect type, adds proper display of artifact activation messages, and moves potions to the new code.

Also unifies some bad effects between mushrooms and potions; change duration dice of some effects to more aesethically pleasing.

new issues:

  • descriptions need proof-reading
  • some effects may still be using "break;" rather than "return TRUE;"

comment:6 Changed 10 years ago by takkaria

report: "Attempting to read the scroll of trap detection on the ground in my square gives the message "Oops. That object cannot be activated." Other scrolls seem OK. I don't know if all trap detection scrolls ause this issue or only this particular one, since I normally use the spell."

comment:7 Changed 10 years ago by takkaria

[4360edf] (SVN r325) finishes off objects for now, including all the issues noted above. Spells yet to be done.

comment:8 Changed 10 years ago by takkaria

  • Owner takkaria deleted
  • Status changed from assigned to new

assigning to no-one, since I'm not working on this for a while

comment:9 Changed 9 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.2 beta

comment:10 Changed 8 years ago by magnate

  • Keywords cleanup added

comment:11 Changed 7 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:12 Changed 7 years ago by magnate

  • Type changed from change to task

comment:13 Changed 6 years ago by magnate

  • Milestone changed from 3.3.0 to Future
  • Status changed from new to confirmed

Punting in accordance with new milestone policy (that any other milestone is only set once someone is actually working on the ticket).

comment:14 Changed 4 years ago by takkaria

  • Milestone changed from Future to 3.5.0
  • Owner set to takkaria
  • Status changed from confirmed to assigned

I want to do this for 3.5.

comment:15 Changed 4 years ago by takkaria

  • Milestone changed from 3.5.0 to Future

Punting to post 3.5.

comment:16 Changed 2 years ago by nckmccnnll

I believe this was finished by about [3a8dc1c]

comment:17 Changed 2 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.