Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#237 closed bug (duplicate)

Windows Angband reacts to clicks while in the background

Reported by: ctate@… Owned by:
Milestone: Keywords: windows
Cc:

Description

If the Angband window is clicked when it is not frontmost, it should not interpret that click as a game action. Right now, it reacts to the click -- if you're in a store, for example, bringing the window forwards can also be interpreted as trying to purchase something.

Change History (3)

comment:1 Changed 7 years ago by takkaria

  • Summary changed from Windows Angband wrongly reacts to clicks while in the background to Windows Angband reacts to clicks while in the background

I'm not at all convinced that this is wrong behaviour. Every other application I've ever used does it, too. I'm not sure we can even tell if a click brings us into focus or not.

comment:2 Changed 7 years ago by takkaria

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #197.

comment:3 Changed 5 years ago by magnate

  • Keywords windows added
  • Milestone 3.2.0 deleted
Note: See TracTickets for help on using tickets.