Opened 10 years ago

Closed 10 years ago

#270 closed bug (fixed (in master))

No transparency for items/player/monsters

Reported by: bjh45964@… Owned by:
Milestone: 3.1.0 Keywords: mac
Cc:

Description

Items monsters and player no longer have transparency, whereas in 3.06 these were blended with the tile behind them.

Change History (9)

comment:1 Changed 10 years ago by takkaria

  • Milestone changed from 3.0.9 to 3.0.8fix1

Please give what OS you're using, its version, and what version of Angband you were playing. Thanks.

comment:2 Changed 10 years ago by bjh45964@…

Sorry, should have known better . . .

OS X 10.4.10, Angband Version 3.08 final

comment:3 Changed 10 years ago by bjh45964@…

I opened up 32x32.png in photoshop, used the background eraser to remove the black background, making it transparent. This worked, though previous versions had black background in png as well. Thought maybe there was somehow a mask layer, or alpha layer in the old png, tried 32x32.png from 3.06 and had the same problem. Is the game actually doing some sort of color based masking?

comment:4 Changed 10 years ago by takkaria

  • Keywords port osx added

comment:5 Changed 10 years ago by bjh45964@…

Anyone know if there are png's out there with black background already removed? I don't want to waste a day removing it if someone has done it already.

comment:6 Changed 10 years ago by takkaria

I don't know anything about this myself, and the person who did work for the Mac port isn't around much at the moment. I know that the colour at (0, 0) in the PNG should be treated as transparent, but that's about the limit of my knowledge when it comes to graphics.

comment:7 Changed 10 years ago by andrewdoull

Look at http://developer.berlios.de/project/showfiles.php?group_id=331&release_id=1889 (release highlighted in red) including the release notes and see if this is what you want.

Note that the mask32.bmp is a separate 2-colour file that can be used as the alpha channel for the PNG.

You can tell if you've got this right, because you should be able to see the legs on ants which are RGB(0,0,0) but not index colour 0.

comment:8 Changed 10 years ago by takkaria

  • Keywords mac added; port osx removed
  • Milestone changed from 3.2.0 to 3.1.0

comment:9 Changed 10 years ago by takkaria

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [d02785b] (SVN r767).

Note: See TracTickets for help on using tickets.