Opened 10 years ago

Closed 10 years ago

#290 closed bug (worksforme)

Stat reduction attacks reduce already-minimum stats

Reported by: takkaria Owned by:
Milestone: 3.1.0 Keywords:
Cc:

Description

CHR 3 character attacked by a rot jelly; CHR not reduced, but turns yellow and gives message anyway.

Change History (3)

comment:1 Changed 10 years ago by takkaria

spells1.c:dec_stat() has the logic for this, but it doesn't take into account maximise mode -- this is where the problem lies. I grok that code well enough to fix it.

comment:2 Changed 10 years ago by takkaria

  • Milestone changed from Future to 3.1.0

comment:3 Changed 10 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

Having tested this in [ba890d7] (SVN r935), I can't reproduce; when the stat system goes linear this code will be rewritten anyway. So, closing as "worksforme".

Note: See TracTickets for help on using tickets.