Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#294 closed bug (fixed (in master))

Dummy object recall issues

Reported by: takkaria Owned by: magnate
Milestone: 3.1.2 beta Keywords: recall
Cc:

Description (last modified by magnate)

Like "It decreases your tunneling by 0".

Change History (10)

comment:1 Changed 8 years ago by magnate

  • Resolution set to fixed
  • Status changed from new to closed

I can no longer reproduce this so assume it has been fixed. Please reopen if not.

comment:2 Changed 8 years ago by takkaria

  • Resolution fixed deleted
  • Status changed from closed to reopened

Well, if it doesn't induce strange messages, then it should. This is basically the bug where object descriptions aren't in any way generic enough to write "This ego-item will increase your speed" messages; instead it will print "+0 to speed" or nothing at all.

comment:3 Changed 8 years ago by magnate

Ah. I think I understand. When I 'r'ecall a helm of intelligence from the knowledge menus, it just says "Sustains intelligence", and you want it also to say "adds to your intelligence".

So we need a way of allowing object_desc to distinguish whether we're describing a specific object or an object type - so that we can use the actual pval for the former and use "adds to" for the latter.

Apologies for the over-zealous close.

comment:4 Changed 8 years ago by magnate

  • Description modified (diff)
  • Keywords recall added

comment:5 Changed 7 years ago by magnate

  • Owner set to magnate
  • Status changed from reopened to assigned
  • Summary changed from When 'r'ecalling items or ego-items, the lack of pval induces strange messages to Dummy object recall issues

This is actually part of a whole host of problems arising from the creation of "dummy" objects for the recall lore functions. Various things are missing from the dummy objects, like tval and pval, which make certain bits of obj-info.c fall over. I think we need yet another boolean for the object_info_out function: whether the object being described is generic (as in, we're describing a type of object which "increases your strength") or specific (as in, we're describing a specific object which "increases your strength by 2"). Will try and have a go at this.

comment:6 Changed 7 years ago by magnate

Noz suggests that the best place to record whether an object is a "dummy" or not is in the o_ptr structure itself. An unused TR3_ flag could be used for this. Probably neater than my idea above.

comment:7 Changed 7 years ago by magnate

Takkaria prefers a "bool dummy" added to object_info_out. This makes four bools: full, terse, subjective and dummy - which could form the basis of a mode bitflag along the lines of the ODESC mode used for object naming. This would allow for further tweaking of object_info in future.

comment:8 Changed 7 years ago by magnate

[e1ec1b7] (SVN r1737) introduces the OINFO_FOO mode flag. Now all we need to do is work out how to describe a dummy ego item of unspecified pval. Since we already deal with unknown pvals on real items, this shouldn't be too hard.

comment:9 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

[e156a10] (SVN r1740)

comment:10 Changed 7 years ago by magnate

  • Milestone changed from 3.2.0 to 3.1.2 beta
Note: See TracTickets for help on using tickets.