Opened 10 years ago

Closed 7 years ago

#325 closed bug (invalid)

Using single items on floor requires extra prompt

Reported by: takkaria Owned by:
Milestone: Triage Keywords: commands
Cc:

Description

From forum, 3.0.9 release thread: "I just tried wielding a lantern off the floor, and it prompted me to select which floor item I wanted, even though there was only the one item."

Is this a bug or a feature?

Change History (7)

comment:1 Changed 10 years ago by takkaria

  • Milestone changed from 3.1.1 to Future

Milestone 3.1.1 deleted

comment:2 Changed 10 years ago by mikon

I filed it as an Un bug, until I found I can select the only item just by pressing 'minus' the second time. No problem now and the UI is consistent.

comment:3 Changed 8 years ago by magnate

  • Keywords commands added

comment:4 Changed 7 years ago by magnate

  • Status changed from new to confirmed

Confirmed still extant in 3.2rc1

comment:5 Changed 7 years ago by magnate

  • Summary changed from Single items on floor require extra prompt to Using single items on floor requires extra prompt

Note that this only applies to wielding/using, not to picking up.

comment:6 Changed 7 years ago by takkaria

  • Resolution set to invalid
  • Status changed from confirmed to closed

This is not a bug. For consistency we should always display a menu, and '-' does indeed just take the first item.

comment:7 Changed 6 years ago by magnate

  • Milestone changed from Future to Triage
Note: See TracTickets for help on using tickets.