Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#376 closed bug (worksforme)

Odd stacking bug

Reported by: takkaria Owned by:
Milestone: 3.1.0 Keywords:
Cc:

Description (last modified by takkaria)

Basically, two spellbooks seem not to be stacking at all. Upgrade savefile from 3.0.6.

Screenshot: http://angband.oook.cz/forum/attachment.php?attachmentid=10&d=1187913152

http://angband.oook.cz/forum/showthread.php?t=218

Attachments (1)

savefile (47.7 KB) - added by takkaria 10 years ago.
Savefile reproducing bug

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by takkaria

Savefile reproducing bug

comment:1 Changed 10 years ago by takkaria

  • Description modified (diff)

comment:2 Changed 10 years ago by shanoah

One of the two spellbooks has ident set to have the flag IDENT_KNOWN, but the other has no flags at all on ident. And naturally, you can't combine identified and unidentified items, even is one is not supposed to be able to be unidentified...

comment:3 follow-up: Changed 10 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

How really very odd. I hope this never crops up again, since I don't know how to fix it. If it does, a new bug can be filed. I hope it's just a savefile conversion issue of some kind.

comment:4 in reply to: ↑ 3 Changed 9 years ago by eddiegrove@…

Replying to takkaria:

How really very odd. I hope this never crops up again, since I don't know how to fix it. If it does, a new bug can be filed. I hope it's just a savefile conversion issue of some kind.

I think my personal changes would work here. I try to make it so that identical things stack, regardless of knowledge. IMO merge should be independent of knowledge and then if things merge knowledge should be ORed, including pseudo knowledge.

Note: See TracTickets for help on using tickets.