Opened 10 years ago

Closed 9 years ago

#385 closed bug (worksforme)

Player position moves sometimes when opening player file

Reported by: Adam Randall <randalla@…> Owned by:
Milestone: 3.1.0 Keywords: waiting
Cc:

Description

It seems that randomly, the player starting position when opening a saved player file can differ one square from where the player was when they quit angband. This is happening on the town level for me, so I don't know if it's happening in the dungeon.

Here's what you can do to reproduce this on OS X:

Move the character to the bottom left most corner. Move NE one space (9-key on numeric pad). Save and quit.
Launch angband, open player.
Using the terminal, killall -9 angband

Do the above two steps and notice that every once in awhile, the character will move down one position.

Attachments (1)

Fingolin (41.0 KB) - added by Adam Randall <randalla@…> 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Adam Randall <randalla@…>

comment:1 Changed 9 years ago by takkaria

  • Keywords close-oct added

can't reproduce. can you still reproduce it?

comment:2 Changed 9 years ago by takkaria

  • Keywords waiting added; close-oct removed

comment:3 Changed 9 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this at all. Closing.

Note: See TracTickets for help on using tickets.