Opened 10 years ago

Closed 10 years ago

#390 closed bug (worksforme)

X11 and GTK ports use 100% CPU

Reported by: ekolis Owned by:
Milestone: 3.1.0 Keywords: closing
Cc:

Description

The X11 and GTK ports are really slow now (especially the GTK port - the run command is no fun!) and prone to freezing. My CPU usage jumps to 100% when either of these is running.

Change History (6)

comment:1 Changed 10 years ago by arcum42@…

The Gtk port I could see - It's had a lot of major revisions, and hasn't really been optimized yet. I've just commited changes yesterday that brought down the memory usage (though it's still higher then it should be), and may help. At that, I was only seeing 10% or so cpu usage - less when you get past the birth screen.

X11 hasn't changed much, and seemed to be running pretty fast, last time I looked.

I'm running it one fairly fast hardware, though. I'll have to find a way to test it on a machine with lower specs. And I'll continue to see what I can do to speed it up a bit, and thrash the processor less...

--Shanoah

comment:2 Changed 10 years ago by ekolis

I'm running a 3 GHZ Pentium 4, so I don't think CPU speed is an issue here - actually, it seems that the X11 port isn't so much slow as it freezes when exiting the options menu...

comment:3 Changed 10 years ago by takkaria

Please can you give details of what distribution you're using, the revision you're using, and a set of steps to reproduce whatever problems are there? I can't reproduce this, using [a74fc96] (SVN r571).

comment:4 Changed 10 years ago by takkaria

If you keep on seeing this issue, then please comment on this bug in the next few days or I'll close it.

comment:5 Changed 10 years ago by takkaria

  • Keywords closing added

comment:6 Changed 10 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.