Opened 10 years ago

Closed 9 years ago

#392 closed bug (worksforme)

Savefile crashes GTK port

Reported by: ekolis Owned by:
Milestone: 3.1.0 Keywords: waiting
Cc:

Description

This savefile seems to crash the GTK port - I was playing merrily along in GTK, then the game crashed. Out of curiosity I tried X11 and SDL, and those seemed to work, but even after saving in one of those and opening it up again in GTK, the game crashes.

Attachments (2)

1000.Ed (46.7 KB) - added by ekolis 10 years ago.
GTK-crashing savefile
Ed (46.7 KB) - added by arcum42@… 10 years ago.
Opened copy of the savefile

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by ekolis

GTK-crashing savefile

Changed 10 years ago by arcum42@…

Opened copy of the savefile

comment:1 Changed 10 years ago by arcum42@…

Certainly odd. I wasn't able to reproduce it on my side, opened fine with gtk. Can you do a backtrace on it? (load with gdb angband, type run, and when it crashes, type backtrace and attach the results.)

Also, what revision are you on (since svn has been updated twice in the last week with gtk changes), and does it make a difference what windows you have open, or if graphics are on?

I've attached a copy of the savefile I loaded in gtk, moved a turn or two and saved on, btw. I'm curious if that'll still crash or not...

comment:2 Changed 10 years ago by anonymous

Well, I can't run the GTK port right now, because compiling with --enable-gtk says that depth_in_feet is undefined. Maybe I had some cached object files somewhere that were incompatible with the newly compiled ones the last time I ran make... that might explain why I got a crash and you didn't...

comment:3 Changed 10 years ago by ekolis

Gah! Someone needs to set up a login system so I don't go around posting comments as anonymous all the time :P

comment:4 Changed 10 years ago by arcum42@…

Possible - define_in_feet is from option.h, so it certainly should come through. I'd recommend running make clean, then doing ./configure and make again, and see if that helps. Or, if it comes down to it, downloading svn in a different folder, compiling, and copying saved games over. (I've ended up doing that a time or two in the past).

Alternatively, uncommenting /*#define DISABLE_GTK_TESTING*/ in main-gtk.c would disable that section of code, but a bunch of the new windows won't work if you do that, so it's a tradeoff.

comment:5 Changed 10 years ago by arcum42@…

Never mind on the first paragraph, actually - the option for depth in feet disappeared on me 18 hours ago in svn, and I hadn't updated the gtk port yet. The second will take care of it, and I'll update gtk soon - probably later tonight.

comment:6 Changed 10 years ago by arcum42@…

It's been updated to compile again; I just wanted to straighten up and commit a few other changes first...

comment:7 Changed 9 years ago by takkaria

  • Keywords waiting added

Are you still experiencing this problem?

comment:8 Changed 9 years ago by anonymous

Oh, sorry, no longer running Linux so I can't test it... unless the GTK port happens to run on Windows now?

comment:9 Changed 9 years ago by shanoah

  • Resolution set to worksforme
  • Status changed from new to closed

Though I understand there is a Windows port of Gtk, no, not at the present time. And I've fixed one or two issues since this ticket was filed that *could* have caused the Gtk port to quit unexpectedly when loading a save file, so I'll go ahead and close this for the moment, and a new ticket can be opened if the issue reoccurs...

Note: See TracTickets for help on using tickets.