Opened 10 years ago

Closed 10 years ago

#393 closed bug (worksforme)

crash in 9-14 build

Reported by: ChodTheWacko Owned by:
Milestone: 3.1.0 Keywords:
Cc:

Description

The program got a segv and died.
I don't remember what i was doing - I think just moving around the dungeon, actually.
Not sure.

See dr. watson logs below

Attachments (2)

drwtsn32.log (23.2 KB) - added by anonymous 10 years ago.
user.dmp (16.9 KB) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by anonymous

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by anonymous

It happened again with the 9-19 build.
Different offsets, but I'm pretty sure it's the same thing.
It happened when I cast a spell.

function: angband

0046d74e 43 inc ebx
0046d74f 0e push cs
0046d750 8d65f4 lea esp,[ebp-0xc]
0046d753 5b pop ebx
0046d754 5e pop esi
0046d755 5f pop edi
0046d756 5d pop ebp
0046d757 c3 ret
0046d758 8b5a04 mov ebx,[edx+0x4]
0046d75b 83ec0c sub esp,0xc

FAULT ->0046d75e 8b4304 mov eax,[ebx+0x4] ds:0023:00000004=????????

0046d761 8b33 mov esi,[ebx]
0046d763 894204 mov [edx+0x4],eax
0046d766 56 push esi
0046d767 e804320000 call angband+0x70970 (00470970)
0046d76c 8903 mov [ebx],eax
0046d76e 891c24 mov [esp],ebx
0046d771 e8fa310000 call angband+0x70970 (00470970)

comment:2 Changed 10 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.0

comment:3 Changed 10 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

Can't do anything about this; the logs don't help since they don't have debugging symbols. Regretfully closing.

Note: See TracTickets for help on using tickets.