Opened 11 years ago

Closed 6 years ago

#434 closed change (fixed (in master))

Rearrange stores

Reported by: takkaria Owned by:
Milestone: 3.5.0 Keywords: stores
Cc:

Description (last modified by takkaria)

Move to a new model of stores:

  • stock items in bulk in infinite-sized stacks
  • guarantee stocking of certain items in various stores
  • remove the temple
  • add the librarian

Will expand upon more in newsgroup/a-d postings; see also Andrew Doull's plan for stores in UnAngband?. Attached file has planned lists of items for each store.

Attachments (1)

ITEMLISTS (4.6 KB) - added by takkaria 11 years ago.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by takkaria

comment:1 Changed 11 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.1

comment:2 Changed 11 years ago by takkaria

  • Milestone changed from 3.1.1 beta to 3.2.0

comment:3 Changed 11 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.2 beta

comment:6 Changed 10 years ago by magnate

Scumming/buying out stores will persist as long as there are chances between 0 and 100% for a store to stock an item. If the chances are only 0 or 100%, scumming/buying out will stop.

comment:7 Changed 10 years ago by magnate

  • Keywords stores added

http://angband.oook.cz/forum/showthread.php?t=1982 (apologies for not referring to this ticket in that thread ...)

comment:8 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:9 Changed 9 years ago by magnate

  • Status changed from new to confirmed
  • Type changed from bug to change

comment:10 Changed 6 years ago by takkaria

  • Description modified (diff)
  • Milestone changed from 4.0 to 3.5.0
  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Just landed in master - 3497add, 858f5c3, a923cf6.

Note: See TracTickets for help on using tickets.