Opened 6 years ago

Closed 2 years ago

Last modified 2 years ago

#510 closed change (fixed (in v4))

Monsters shouldn't be able to drop items branded against them.

Reported by: takkaria Owned by:
Milestone: 4.0 Keywords: items
Cc:

Description (last modified by takkaria)

The idea that monsters can't pick up items which are branded against them is inconsistent with the logic of allowing them to drop, on death, items with the same brand. Solution: allow them to pick up anything, including artifacts. (But why would they ever actually want to?)

Change History (11)

comment:1 Changed 6 years ago by takkaria

  • Description modified (diff)

comment:2 Changed 5 years ago by stefanor@…

This has icky interactions with preserve-mode; there will need to be a thorough re-examination of how monsters and items can be removed from lists.

comment:3 Changed 5 years ago by magnate

  • Keywords ai added

comment:4 Changed 3 years ago by magnate

  • Status changed from new to confirmed

comment:5 Changed 3 years ago by magnate

  • Type changed from bug to change

comment:6 Changed 3 years ago by GabeCunningham

  • Milestone changed from 4.0 to 3.4.0
  • Owner set to GabeCunningham
  • Status changed from confirmed to assigned

comment:7 Changed 3 years ago by GabeCunningham

  • Milestone changed from 3.4.0 to 4.0
  • Owner GabeCunningham deleted
  • Summary changed from Allow monsters to pick up anything to Monsters shouldn't be able to drop items branded against them.

After discussion at http://angband.oook.cz/forum/showthread.php?t=4825, the general consensus seems to be to leave things the way they are (i.e., keep the monster pickup logic the same as it is). Perhaps monsters shouldn't be allowed to drop items that are branded against them, but that can wait until we have monster drop profiles.

comment:8 Changed 3 years ago by magnate

  • Keywords items added; ai removed

We sort of do have drop profiles, though they are not yet as flexible as #600 aspires to be, so I agree that this ticket follows that one ...

comment:9 Changed 3 years ago by magnate

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:10 Changed 2 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from assigned to closed

[re82f638]

comment:11 Changed 2 years ago by magnate

JFTR, this change was reverted in [b2915f2] because it had a significant impact on the distribution of item properties (e.g. Slay Evil). It might one day be good for monsters to be able to pick up anything, but there's no pressure for that yet.

Note: See TracTickets for help on using tickets.