Opened 12 years ago

Closed 11 years ago

#521 closed bug (fixed (in master))

strange startup hang problem on XP

Reported by: ChodTheWacko Owned by:
Milestone: 3.1.1 beta Keywords:
Cc:

Description

For whatever reason, Angband hangs on my machine during startup if I have a command prompt open.

For example, I can do this:
Okay, well, this is the weirdest thing I've ever seen.

If I run the binary, and I have a 'command prompt' open, Angband hangs at startup. If I exit all command windows, then it will start.
The hanging Angband will also resume if I exit the command prompt.

So I can do something like:
start -> run -> cmd

in the new command prompt:
F:\Documents and Settings\Frank>cd i:\games\angsrc\trunk
F:\Documents and Settings\Frank>i:
I:\games\angsrc\trunk>start angband

(angband hangs)

I:\games\angsrc\trunk>exit
(command prompt closes and angband pops up!)

This also happens with the nightly builds.

This currently always happens on my box - I'm running XP.

Change History (3)

comment:1 Changed 12 years ago by ChodTheWacko

Seems to happen if I use a 'X' font from NPP (NPP 0.5.0 BETA-6).
like 8x12x.fon.

I was told to do this because if I don't I get some annoying 'can't read anything due to text overlap' bug and the game is unplayable.

  • Frank

comment:2 Changed 12 years ago by leandor AT gmail DOT com

The same is happening to me after I updated from 3.0.6

comment:3 Changed 11 years ago by takkaria

  • Milestone changed from 3.2.0 to 3.1.1 beta
  • Resolution set to fixed
  • Status changed from new to closed

in [2d7aeb6] (SVN r1099).

Note: See TracTickets for help on using tickets.