Opened 12 years ago

Closed 11 years ago

#560 closed bug (fixed (in master))

Limit char dumps to 80 characters wide

Reported by: Big Al Owned by:
Milestone: 3.1.0 Keywords:
Cc:

Description

Character dumps should be reformatted a bit to be no more than eighty characters wide. It would make dumps on eg. r.g.r.a a lot easier to read. (see http://angband.oook.cz/rgra.php?showpost=124957 for example - all the stat lines are slightly too long.) It looks like there are enough room in between the sex and age fields (etc.) to remove a few spaces.

Change History (4)

comment:1 Changed 12 years ago by anonymous

They're already below 80 characters-- they would need to be below 72 for this effect to be stopped.

comment:2 Changed 11 years ago by Lebannen

Having just checked this, the dumps already appear to be up to 72 characters exactly. The problem is still quite noticeable - on Google's r.g.r.a. view as well, for example http://groups.google.com/group/rec.games.roguelike.angband/browse_frm/thread/a9f3d397a47a5b7c# .

When using that particular google groups post, the longest lines displayed actually have 72 characters in them. The problem may be that an additional space is added at the start - so maybe the maximum line length is actually 71 characters? However it doesn't look like the angband.oook.cz dumps are including additional spaces, so it may be safer to go to 70 characters to see if that'll fix it.

comment:3 Changed 11 years ago by Lebannen

Even weirder - compare a recent dump from 3.0.5 to r.g.r.a. via google - http://groups.google.com/group/rec.games.roguelike.angband/browse_frm/thread/b1a4177a93959d2e# . The post actually appears to be wider - certainly well above 72 chars - but no problems!

comment:4 Changed 11 years ago by takkaria

  • Resolution set to fixed
  • Status changed from new to closed

Given that the game already wraps at the right width, this is a problem with news clients and not Angband itself. It is thus a fixed bug.

Note: See TracTickets for help on using tickets.