Opened 9 years ago

Last modified 8 years ago

#599 confirmed change

Linearise the stat system

Reported by: takkaria Owned by:
Milestone: v4 Keywords: player
Cc:

Description

Stat potions always increase 1 point beneath 18 and 10 points past that. Store internally as a single index (28 for 18/100, etc.).

Change History (10)

comment:1 Changed 8 years ago by takkaria

  • Resolution set to fixed
  • Status changed from new to closed

first part in [88c38bc] (SVN r1149)

comment:2 Changed 8 years ago by takkaria

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 in reply to: ↑ 3 Changed 8 years ago by magnate

Replying to takkaria:

http://angband.oook.cz/forum/showpost.php?p=17785&postcount=21

This has more to do with the rarity of stat potions than any criticism of linearisation ...

comment:5 Changed 8 years ago by takkaria

  • Milestone changed from 3.1.1 beta to 3.1.2 beta

comment:6 Changed 8 years ago by takkaria

  • Milestone changed from 3.1.2 beta to 3.1.1 beta
  • Status changed from reopened to confirmed

Portions of [88c38bc] (SVN r1149) should be rolled back for 3.1.1, awaiting some better balancing in 3.1.2

comment:7 Changed 8 years ago by takkaria

  • Type changed from task to change

comment:8 Changed 8 years ago by takkaria

  • Milestone changed from 3.1.1 beta to 3.1.2 beta

[80b7929] (SVN r1535) rolls things back a bit. rest is waiting until 3.1.2

comment:9 Changed 8 years ago by magnate

  • Keywords player added

comment:10 Changed 6 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

Note: See TracTickets for help on using tickets.