Opened 10 years ago

Closed 7 years ago

#631 closed bug (fixed (in master))

Incoherent behavior when enchanting/disenchanting items

Reported by: anonymous Owned by: artes
Milestone: 3.4.0 Keywords: items
Cc:

Description (last modified by takkaria)

Here's the current behavior:

  • Enchanting to-hit/to-dam:
    • weapon/bow: yes
    • ring/amulet: no
    • armor part: no
  • Disenchanting to-hit/to-dam:
    • weapon/bow: yes
    • ring/amulet: no
    • armor part: yes
  • Enchanting to-ac:
    • weapon/bow: no
    • ring/amulet: no
    • armor part: yes
  • Disenchanting to-ac:
    • weapon/bow: yes
    • ring/amulet: no
    • armor part: yes

What seems incoherent here is the following:

  • armor parts can lose to-hit/to-dam but can never get it back (ego gloves)
  • armor parts can lose to-hit/to-dam, but not rings/amulets (amulets of weaponmastery...)
  • weapons can lose to-ac but can never get it back (defenders, holy avengers...)
  • weapons can lose to-ac, but not rings/amulets (rings of flame, amulets of the magi...)

I would suggest to limit disenchantment to innate bonuses: to-hit/to-dam for wielded objects, to-ac for worn items. This would fix the problem the easy way.

Change History (6)

comment:1 Changed 10 years ago by takkaria

  • Description modified (diff)
  • Milestone changed from 3.2.0 to 3.1.2 beta

comment:2 Changed 9 years ago by magnate

  • Keywords items added

comment:3 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:4 Changed 8 years ago by magnate

  • Status changed from new to confirmed

comment:5 Changed 7 years ago by artes

  • Owner set to artes
  • Status changed from confirmed to assigned

comment:6 Changed 7 years ago by takkaria

  • Milestone changed from 4.0 to 3.4.0
  • Resolution set to fixed
  • Status changed from assigned to closed

Pull request https://github.com/angband/angband/pull/85, commited as [aa6ed5d].

Note: See TracTickets for help on using tickets.