Attachments (2)

test.txt (12.9 KB) - added by d_m 9 years ago.
random test (utf8 test page)
md_641.patch (6.8 KB) - added by MarbleDice 9 years ago.
Fix quest artifacts, hopefully doesn't break any of the other fragile object generation systems.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by takkaria

  • Resolution set to fixed
  • Status changed from new to closed

I think this should probably have been fixed in [7a237e7] (SVN r1047), as they're basically the same bug.

comment:2 Changed 10 years ago by stefanor@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

It's not fixed. I just killed Morgoth (yay), and my gear is the same (actually worse, Grond was only (+3,+3)). ([2d7aeb6] (SVN r1099))

comment:3 Changed 10 years ago by stefanor@…

Examining this closer, it looks like the setting of artifact type is to blame, as it prevents apply_magic from properly artifacting the objects.

comment:4 Changed 10 years ago by takkaria

  • Resolution set to fixed
  • Status changed from reopened to closed

in [610802e] (SVN r1115)

comment:5 Changed 10 years ago by takkaria

  • Milestone changed from 3.1.0 to 3.1.1 beta

comment:6 Changed 10 years ago by takkaria

  • Description modified (diff)
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 10 years ago by magnate

  • Owner set to magnate
  • Status changed from reopened to assigned

comment:8 Changed 10 years ago by magnate

  • Owner changed from magnate to takkaria

I cannot reproduce this bug. The second forum thread referred to says that the person was using 3.1.0beta ... so maybe this is fixed after all? It certainly seems to work consistently in wizard mode.

comment:9 Changed 10 years ago by takkaria

  • Resolution set to fixed
  • Status changed from assigned to closed

confirmed fixed by killing Morgy normally

comment:10 Changed 9 years ago by magnate

Oh dear. This is still lurking: reported by Psi on Oook using [ccce835] (SVN r1814). Not reopening until this is corroborated.

comment:11 Changed 9 years ago by magnate

  • Milestone changed from 3.1.1 beta to 3.1.2 beta
  • Resolution fixed deleted
  • Status changed from closed to reopened

reopening to try and attach Psi's savefile

Changed 9 years ago by d_m

random test (utf8 test page)

comment:12 Changed 9 years ago by magnate

Eddie confirms that this occurs in [9b60c00] (SVN r1858).

Changed 9 years ago by MarbleDice

Fix quest artifacts, hopefully doesn't break any of the other fragile object generation systems.

comment:13 Changed 9 years ago by MarbleDice

  • Keywords items added
  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed (again) in [2087e79] (SVN r1892).

Note: See TracTickets for help on using tickets.