Opened 10 years ago

Closed 10 years ago

#697 closed change (fixed (in master))

There should be an autotarget nearest monster command

Reported by: takkaria Owned by: d_m
Milestone: 3.1.2 beta Keywords: commands
Cc:

Change History (11)

comment:1 Changed 10 years ago by tigen

I was checking out Crawl (actually Stone Soup ) last week and I think it has a pretty clever UI for this. After you hit f, it auto-targets the nearest creature immediately, and pre-selects a reasonable ammunition. You can change either of the autoselections, but in the common case you can just hit "f,enter" or f,f to shoot the nearest monster. f,f shoots the previous monster.

comment:2 Changed 10 years ago by magnate

Well, Angband has the * key, which finds the nearest monster, so *t effectively does what this ticket asks, either before or during a fire or spell command. I agree that the Crawl UI is good though, so there is always room for improvement. Perhaps postpone this to a later milestone?

comment:3 Changed 10 years ago by magnate

See also #374.

comment:4 Changed 10 years ago by takkaria

  • Milestone changed from 3.1.1 beta to 3.1.2 beta
  • Status changed from new to confirmed
  • Type changed from bug to change

comment:5 Changed 10 years ago by magnate

  • Keywords commands added

comment:6 Changed 10 years ago by d_m

  • Owner set to d_m
  • Status changed from confirmed to assigned

I'm currently working on various targeting UI changes as well as importing the quiver. While I'm not sure I will definitely use Stone Soup's interface, I'm taking ownership of this bug since it's motivations are ones I share.

Please put any (new) targeting suggestions in the comments.

comment:7 Changed 10 years ago by KZK

Going over my notes these are the things that I would consider changing and simplifying with respect to Quivers/Targeting/Slots/Aiming/Zapping/Using/Activating? that I was planning on presenting at later date as things that should be considered for 3.2+, since we are already going to have to rebalance a number of things, why not fix them here now? Keep in mind these these suggestions that are interrelated to each other (but should probably be their own tickets):

Consolidate the 'a'im and 'z'ap (and possibly the 'A'ctivate and 'u'se) commands. They do the same thing practically. 'z'ap wands/Rods. Then change 'A'ctivate to a 'a'ctivate artifacts. Simplifies everything.

Add Slot for digging tool, subtract 1 item slot (or not see below), add partial (1/2) turn penalty for the start and end of digging (to simulate time to change hands for weapon/digger), remove ego attacks for diggers (diggers no longer primary weapons). Make diggers no longer equitable as weapon (wear/wield only equips in the digger slot). You no longer use digger to attack unless no weapon is equipped (with same penalties for digging). Ditch the X macro (no longer needed). Flip the T and t commands (Tunneling is used 1000x as often). This makes it no longer necessary to inscribe T on weapons and . on diggers. No longer the possibility of being interrupted while digging and accidentally attacking with shovel. No longer get caught missing important bonuses/resistances/pluses when a random creature attacks out of nowhere because your weapon is unequipped. No longer have to dig through Vault walls then switch to your weapon when the creature on the other side of the wall essentially gets a free attack.

Same for the quiver. Multiple Quivers can have multiple slots (up to say 4), at the expense of item slots (put last in the equipment list, after the new digger slot, for this reason). No longer a need to inscribe ammo this way (use the permanent quiver slot letter instead). Quivers are automatically filled with ammo of the same type, unknown ammo will still have to be collected in your pack until placed in a quiver or id'd. Also we should expand the types of ammo to thrown weapons like shuriken, throwing daggers, etc. (Which reminds me a huge unfixed bug in Zangband when throwing weapons that magically return from your wield hand Zangband returns it to your pack instead allowing you "create" an infinite amount of that weapon).

In actuality, since we are going to be completely rebalancing the game anyway here (this is 3.2+) and possibly changing things like charisma into stealth as Takkaria has possibly hinted at, and so forth), I think we should make the above changes and move back to using the full number of item slots (or however many it was that fit in a full screen I forget).

Handedness, player can use one hand each for some weapons (daggers, rapiers, shuriken), one hand for a weapon and one hand for a Shield, or both hands for big 2-handed weapons (claymores). This would effect to hit/blows ratios for a second hand etc. This might also affect bow use. For "handedness" have one hand be known as the Weapon Hand, and the other as the Shield Hand (might note which hand the player favors in the inconsequential player history screen). Weapons would need a handedness flag. Should also affect ability throw items from the quivers etc.

The Addition of Rods and the change to stacking has really unbalanced certain aspects of the game. Back a few years ago, wands and staffs took up a single space each. So you had to make actual tradeoffs when keeping/using them. Now you just stack to infinity and don't have to make any hard choices. Rods + stacking makes wands pretty irrelevant now. I almost don't even use them except for very early in the game and the breath ones. You can actually get enough copies of some Rods that you can fire them indefinitely without running out of charges (at least at normal speeds). To alleviate this problem we can do two things: A. make Rods not stack, or limit the number of items in magical stacks (say 3 rods, 5 wands, or 2 Staves). B. Make Rods into Artifact Wands, and limit the number of each type created in the entire game to a small number.

comment:8 follow-up: Changed 10 years ago by KZK

Trac does not like the Carrot symbol(the up arrow on the 6 key).

Should say CarrotT (!T) on weapons and Carrot. (!.) on diggers. (Because the ! notion doesn't work in those cases, otherwise it would be !T and !.).

comment:9 in reply to: ↑ 8 Changed 10 years ago by magnate

Replying to KZK:

Trac does not like the Carrot symbol(the up arrow on the 6 key).

It's called a caret, and Trac likes it very much - for superscripting. To display it, use triple braces around it: ^T

For the record, I use targeting about 1000x as often as I use tunnelling. I'd support a unified use command, but I think both the creation of a digger slot and introducing two-handed weapons are more trouble than they're worth (though S does the latter well). The quiver is coming (see #34), and throwing weapons may follow. I don't think there is a problem with magic devices stacking at the moment - there are still plenty of inventory decisions to make, and plenty of reasons to choose wands over rods. You only find enough rods to obviate wands if you play at borg/Neo pace.

For d_m's benefit: Takkaria has mentioned before that this kind of discussion should take place on Oook/rgra rather than here.

comment:10 Changed 10 years ago by KZK

I Was referring to the 't'ake off command, not targetting which is the wildcard key (*). 't'ake off is almost never used.

The digger slot would simply so many things that it should be looked into. Even if it is a pain to implement, the end product would be worth it.

I think their should be a small turn penalty for throwing/firing items from your pack instead of from a quiver.

comment:11 Changed 10 years ago by d_m

  • Resolution set to fixed
  • Status changed from assigned to closed

I'm closing this bug since (') targets the nearest monster (as per the original ticket) and (h) fires at the nearest monster.

Discussion of a general command revamp should continue on oook or rgra or what-have-you.

Note: See TracTickets for help on using tickets.