Opened 9 years ago

Closed 6 years ago

#720 closed task (fixed (in v4))

Changes to item generation

Reported by: takkaria Owned by: magnate
Milestone: v4 Keywords: items,affixes
Cc:

Description (last modified by magnate)

Now we have full stats for item generation in 3.3.0, we need to reduce the abundance of high-end ego items and artifacts.

Change History (12)

comment:1 Changed 9 years ago by takkaria

  • Milestone changed from 3.1.1 beta to 3.1.2 beta
  • Status changed from new to confirmed
  • Type changed from bug to task

comment:2 Changed 9 years ago by magnate

  • Keywords items added

comment:3 Changed 9 years ago by magnate

See also #786 and #192

comment:4 Changed 8 years ago by magnate

This thread discusses two possible changes to item generation: changing the MAX(mlev, dlev) of a drop, and making certain consumables GOOD again.

http://angband.oook.cz/forum/showthread.php?t=2491

comment:5 Changed 8 years ago by magnate

This thread gives some feedback on the severity of the overabundance of ego items in 3.1.2:

http://angband.oook.cz/forum/showthread.php?t=2885

#1080 will solve some of the issues, but we also need to make the good-to-great transition slightly rarer (which will in turn make artifacts rarer), and I think we could reduce weapon and armour drops altogether (as there is not a lot of call for non-ego weapons or armour for ~90% of the game).

comment:6 Changed 7 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:7 Changed 7 years ago by magnate

  • Milestone changed from 3.3.0 to Future

Punting in accordance with new milestone policy (that any other milestone is only set once someone is actually working on the ticket).

comment:8 Changed 6 years ago by magnate

  • Description modified (diff)
  • Milestone changed from Future to 3.4.0
  • Owner set to magnate
  • Status changed from confirmed to assigned
  • Summary changed from Check to see how rare/common certain item kinds are again to Changes to item generation

I'm now repurposing this ticket to be about the changes to item generation intended to make ego items and artifacts less common. Of particular importance is the need for a more granular alloc_prob scale (1-1000 instead of 1-100).

comment:9 Changed 6 years ago by magnate

  • Status changed from assigned to pending

These are all done (or at least underway) in http://github.com/magnate/angband/tree/affixes.

comment:10 Changed 6 years ago by magnate

  • Keywords items,affixes added; items removed

This ticket is addressed in (or enabled by) https://github.com/angband/angband/pull/94

comment:11 Changed 6 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:12 Changed 6 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from pending to closed

Fixed in the affixes merge [r48ccc16f]

Note: See TracTickets for help on using tickets.