Opened 10 years ago

Closed 7 years ago

#800 closed change (fixed (in v4))

Sort out bucklers

Reported by: magnate Owned by: magnate
Milestone: v4 Keywords: items
Cc:

Description

Prior to [3d69058] (SVN r1231), bucklers were given an sval in object/tvalsval.h, but were commented out in object.txt

In [3d69058] (SVN r1231) they were commented out in tvalsval.h as well

If we want to use them (and one reason would be that they provide another source of interesting low power randarts, because they have such low intrinsic value that they can get more abilities), we need to uncomment them in both object.txt and tvalsval.h (and add them back into randart.c). We would also need a graphics tile for them.

Change History (6)

comment:1 Changed 10 years ago by magnate

  • Keywords items added

comment:2 Changed 9 years ago by magnate

  • Milestone changed from Future to 3.1.3
  • Owner set to magnate
  • Status changed from new to assigned

Graphics tiles provided by buzzkill for bucklers and gloves of mining: http://angband.oook.cz/forum/showthread.php?t=2924

Guess we still need them for the 8x8 and 16x16 tile sets, or we could use duplicates?

comment:3 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:4 Changed 8 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0

comment:5 Changed 7 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:6 Changed 7 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from assigned to closed

Fixed in [r02dd343efc]

Note: See TracTickets for help on using tickets.