Opened 10 years ago

Closed 4 years ago

#808 closed task (fixed (in master))

Savefile: save monster memory records sparsely

Reported by: takkaria Owned by: magnate
Milestone: Future Keywords: loadsave
Cc:

Description

That is, only save data for monsters there's data held about. This should reduce the size of savefiles a lot.

Change History (9)

comment:1 Changed 10 years ago by takkaria

  • Milestone changed from Triage to 3.1.2 beta

comment:2 Changed 10 years ago by magnate

  • Keywords loadsave added

comment:3 Changed 10 years ago by magnate

No need to do this if #950 is implemented.

comment:4 Changed 10 years ago by takkaria

I'd hope that if monster recall were split it out, it were done in a sparse format too.

comment:5 Changed 9 years ago by magnate

  • Milestone changed from 3.1.2 beta to 3.1.3
  • Owner set to magnate
  • Status changed from new to assigned
  • Type changed from bug to change

Changing milestone to match #950.

comment:6 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Postponing until 3.3

comment:7 Changed 8 years ago by magnate

  • Type changed from change to task

comment:8 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to Future
  • Status changed from assigned to confirmed

Punting in accordance with new milestone policy (that any other milestone is only set once someone is actually working on the ticket).

comment:9 Changed 4 years ago by nckmccnnll

  • Resolution set to fixed (in master)
  • Status changed from confirmed to closed

Unnecessary due to resolution of #950

Note: See TracTickets for help on using tickets.